Cheap Computers

Are they worth it? Financially, yes. Time-wise, no.

We got a machine with a Pentium [email protected] with 256MB of RAM, a 10GB HD, and no operating system for $116. This was opposed to the $226 P4 Celeron @ 2.4Ghz with 512MB of RAM and XP Home. All we need this machine for is light surfing and word processing, so that’s why we went with the one that cost almost half as much.

Right off, the machine was annoying, throwing up a “1801 PCI/PNP error! No space available to shadow ROM,” when it POSTed. It annoyed me that the guy that sold it to me knew about it (I saw him test its ability to POST) but didn’t tell me. I didn’t really know what it meant, but some light Googling turned up that I had to disable the ROM shadowing, which was unchangeable with my current BIOS. :\ It wasn’t all that much trouble, as I had either the option of continuing, or entering BIOS setup, and it would continue in 5 seconds automatically. I think I might have noticed at that point that the hard drive was not detected in BIOS, but I didn’t do much about it, I’m not sure why.

I booted into Ubuntu, and it took a while to load the LiveCD thanks to the horribly slow CD drive. Don’t get me wrong, Ubuntu is great, but on this drive, it took a long time to load. What made it even worse was that once I crawled through the installer and got to the partion stage, there were no devices detected to install to. I booted into GParted to confirm, and BIOS cemented it. I assumed the drive was dead, and started trying to make a Damn Small Linux bootable USB drive to have the machine still be usable. After it failed to boot into a FAT32 USB stick, I was about to try FAT when I checked to see if the HD was indeed plugged in. Data was plugged in, but power wasn’t. I had just spent an hour or more trying to get around an undetected HD, and it was just an unplugged cable!

I booted into GParted and easily made an ext3 partition and 509mb of swap. I pulled up Ubuntu again, repartitioned to use up all the drive space, finished the other stuff, then mashed the install button and left it alone. It took a while, due to the CD drive still insisting on being slow. I could’ve taken my faster drive from my server and popped it in there, but that would mean downtime, and I’m trying to have a high uptime so I can brag about it.

The install finished after what seemed like a little over half an hour, and the machine rebooted and pulled up the OS. The sound worked right out of the box, so did the networking. My sister settled down and seemed to like it. Mission accomplished! 🙂

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.